New venus showing only random selection of posts [runtests.py errors]

Sam Ruby rubys at intertwingly.net
Fri May 21 08:19:30 EST 2010


On 05/20/2010 05:39 PM, Mikael Nilsson wrote:
> Right, so with your latest commit the "links" error is gone, replaced by
> *lots* of debug prints like
>
> DEBUG:planet.runner:missing self link for http://magnihasa.blogspot.com/feeds/posts/default/-/Piratrelaterat?alt=rss
> DEBUG:planet.runner:missing html link for http://magnihasa.blogspot.com/feeds/posts/default/-/Piratrelaterat?alt=rss
> DEBUG:planet.runner:missing self link for http://christianengstrom.wordpress.com/feed/
> DEBUG:planet.runner:missing html link for http://christianengstrom.wordpress.com/feed/
> DEBUG:planet.runner:missing self link for http://ershag.se/feed/
> DEBUG:planet.runner:missing html link for http://ershag.se/feed/
>
> which seem to coincide with the sources not being shown.
>
> The corresponding feeds do exist on disk, even the individual posts are
> generated in the cache directory. Something is wrong in the reloading of
> the posts.

Inside the cache directory, there is a subdirectory named sources. 
There should be one file there per subscription.  Can you visually 
compare one of the ones that is skipped against one that matches a 
source that is being shown to see if there is any obvious difference? 
Feel free to post (or send me directly) one of each (these files are 
typically only a kilo-byte or two).

Also, in the output is there any output that starts with the word 
"Skipping:"?

> /Mikael

- Sam Ruby


More information about the devel mailing list